Results 1 to 6 of 6

Thread: Astroart6 and FotoDIF problem: NAXIS=32 format not valid

  1. #1
    Junior Member
    Join Date
    Jun 2016
    Location
    Gran Canaria, SPAIN
    Posts
    6

    Astroart6 and FotoDIF problem: NAXIS=32 format not valid

    Hello, I have used Astroart 6 to get images and darks. I've applied Darks and aligned the images so I got a set of _P.fit files.The problem arose when I tried to use Fotodif to do photometry, as usual.Fotodif said that The format used by Astroart is not valid: NAXIS=32What can I do? ThanksCarlos

  2. #2
    Developer
    Join Date
    Apr 2012
    Posts
    408
    Hello, are you sure about NAXIS=32? Maybe it's BITPIX=32. Please check with a text viewer or post the image.

    BITPIX=32 means that the file is saved as 32 bit FITS, because its range exceeded the 16 bit dynamic (0..65535).
    This can happen if you chose "Add" instead of "Average" as combine method in Preprocessing, or if you used a imprecise dark frame (too strong) so that it caused negative pixels. Another cause could be an imprecise darkframe + a damaged CCD border. In this case you could solve enabling the option "Cut border" in Preprocessing.
    Another solution is to suggest support of 32 bit FITS in Fotodif, it's very easy to do.

  3. #3
    Junior Member
    Join Date
    Jun 2016
    Location
    Gran Canaria, SPAIN
    Posts
    6
    Hi, yes, let me attach the screenshot.
    Thanks for the help.


    Carlos
    Attached Thumbnails Attached Thumbnails Screenshot_3.png  

  4. #4
    Junior Member
    Join Date
    Jun 2016
    Location
    Gran Canaria, SPAIN
    Posts
    6
    And a sample image:
    http://bit.ly/2hEepiX
    Carlos

  5. #5
    Developer
    Join Date
    Apr 2012
    Posts
    408
    Hello, your image has NAXIS = 2 , you can verify that with a text viewer, opening your image as text:

    Click image for larger version. 

Name:	img_1_header.png 
Views:	1 
Size:	10.7 KB 
ID:	221

    This is from the "lister" of Total Commander.

    You can prevent negative pixels (so saving as 32 bit FITS) removing the leftmost columns of your image: in Preprocessing, page "Extra", enable "Cut Borders", setting the "Left" Field = 1
    By the way, check also the temperature of your (master) dark frame.

  6. #6
    Junior Member
    Join Date
    Jun 2016
    Location
    Gran Canaria, SPAIN
    Posts
    6
    Thanks!!!
    It works!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •